(Cyro) Mouse DPI and offset-angle settings keep resetting to default on their own randomly

Vedsetta

New member
Sep 4, 2023
2
0
1
I have my DPI set to 1850 and my offset angle at 20, that's what's comfortable to me with the Cyro. But ever since yesterday the DPI seemingly doubles and the offset angle resets to 0 degrees, which completely throws my muscle memory off and, with how many times this has happened, becomes frustrating to navigate. This is happening every few minutes, and I only have one profile on both "ON BOARD" profiles and "SOFTWARE" profiles, both with the exact same settings. The only fix I have right now is swapping between my "SOFTWARE" and "ON BOARD" profiles, and that only works for a couple minutes (if that) before the settings go out of whack again. This happened out of nowhere and I have no idea what's causing it.

Any ideas on how to fix it?
 

Im this guy

Moderator
Staff member
Nov 5, 2021
1,078
127
63
I have my DPI set to 1850 and my offset angle at 20, that's what's comfortable to me with the Cyro. But ever since yesterday the DPI seemingly doubles and the offset angle resets to 0 degrees, which completely throws my muscle memory off and, with how many times this has happened, becomes frustrating to navigate. This is happening every few minutes, and I only have one profile on both "ON BOARD" profiles and "SOFTWARE" profiles, both with the exact same settings. The only fix I have right now is swapping between my "SOFTWARE" and "ON BOARD" profiles, and that only works for a couple minutes (if that) before the settings go out of whack again. This happened out of nowhere and I have no idea what's causing it.

Any ideas on how to fix it?
Sounds like a static electricity damage.
Email us on info@azeron.eu, state your order number and issue.