My cyborg keypad is not working

noguel

New member
Nov 11, 2023
2
0
1
I updated the fireware and software and now it's not working, and I didn't safe the profile.
I need help!
 

noguel

New member
Nov 11, 2023
2
0
1
This cyborg does not have a reset button, plus I used the guides and it is not possible to factory reset.
 

Im this guy

Moderator
Staff member
Nov 5, 2021
979
112
43
This cyborg does not have a reset button, plus I used the guides and it is not possible to factory reset.
Does the device manager see it when plugged in ?
Do the LED lights come on ?
Do you hear the usb chime when plugging in ?

Safest bet -
->
 

Blinkerfluid

New member
Nov 23, 2023
4
0
1
these videos are very confusing and did not help at all. Is there any way to actually contact some form of customer support from Azeron? going to the website listed in the first video info@azeron.eu just takes me to there store page. When I plug in my Cyborg keypad the lights come on, I hear the chime, it is listed in my devices, but the soft ware just tells me to "select your device" but provides no options to choose from.
 
Last edited:

Im this guy

Moderator
Staff member
Nov 5, 2021
979
112
43
these videos are very confusing and did not help at all. Is there any way to actually contact some form of customer support from Azeron? going to the website listed in the first video info@azeron.eu just takes me to there store page. When I plug in my Cyborg keypad the lights come on, I hear the chime, it is listed in my devices, but the soft ware just tells me to "select your device" but provides no options to choose from.
you can email us on info@azeron.eu

In your case, check on whether any other controllers are coming up in the device manager and bluetooth and devices. If there are, remove them and then restart the PC and check.
Check whether the usb cable is fully plugged in (lights doesn't mean that the connection is secure, data might not be getting through). Plug it in a moherboard usb port and test.
 

Blinkerfluid

New member
Nov 23, 2023
4
0
1
you can email us on info@azeron.eu

In your case, check on whether any other controllers are coming up in the device manager and bluetooth and devices. If there are, remove them and then restart the PC and check.
Check whether the usb cable is fully plugged in (lights doesn't mean that the connection is secure, data might not be getting through). Plug it in a moherboard usb port and test.
No other controllers are in the device manager. Only the keyboard, mouse and Azeron Cyborg. It doesn't matter which USB port I plug into, directly connected to the motherboard or not.
 

Im this guy

Moderator
Staff member
Nov 5, 2021
979
112
43
No other controllers are in the device manager. Only the keyboard, mouse and Azeron Cyborg. It doesn't matter which USB port I plug into, directly connected to the motherboard or not.
Do the LEDS change when pressing the profile switch ?
Go in the software / settings / having trouble and export the log and thick to include logs.
Email them on info@azeron.eu or you can attach it here