Two Buttons linked together

Kiligan

New member
Jan 24, 2023
2
1
1
Hi,
I received my new Azeron Cyborg today. Love it so far.
Software version 1.1.2 Beta

My problem now is that
In the configuration menu, button #11 and #12 are always pressed together as if they were connected.
No matter which of the two I press, always the same.

Changing profile or assigning a different button has done nothing.

Is there a way to fix the problem?
 

Steve

New member
Mar 15, 2022
3
2
3
I don't know much, but to me it sounds like there might be a connection issue. Maybe a wire touching both buttons? Sounds unlikely thought due to how they are put together. If you are comfortable removing some screws you can look inside and look at the wires connected to those 2 buttons. One of the wires might be exposed meaning both get a signal when either is pressed.

Again I know little about this, this is just the way it makes sense when I think about it. I could be way off.
 

Im this guy

Moderator
Staff member
Nov 5, 2021
459
68
28
Hi,
I received my new Azeron Cyborg today. Love it so far.
Software version 1.1.2 Beta

My problem now is that
In the configuration menu, button #11 and #12 are always pressed together as if they were connected.
No matter which of the two I press, always the same.

Changing profile or assigning a different button has done nothing.

Is there a way to fix the problem?
The wires are touching somewhere.
It can be either under PCB board or in the tower itself.


First thing you can do is to take the palm rest off and then unscrew two screws that hold the board down. Then lift the board up and connect the usb cable and test if the issue still persists. If it does, then the wires are touching inside the tower.
 

Im this guy

Moderator
Staff member
Nov 5, 2021
459
68
28
1674637948248.png